Tech Self Help Articles » iMistAway »iMist2 Troubleshooting: “Unit Not Connected to Gateway – Node Not Responsive”

iMist2 Troubleshooting: “Unit Not Connected to Gateway – Node Not Responsive”

The iMist gateway is connected to the internet but it is not communicating with the node on the misting unit.

Potential Cause:

  • The node’s processor has locked up or gotten “stuck”
  • The gateway or node has failed.

Troubleshooting:

To confirm the issue, open the Connection tab for the unit on iMistAway.com.

You’ll see that the Gateway Connection Status will indicate that it is online with a time stamp showing the current date and time. The Current Signal Strength in the “Unit” box will be Excellent, Good, or Marginal but the time stamp will show a date and time in the past that exceeds an expected 1 – 2 hour difference, as shown below.

Solution:

You or your customer will need to perform the following steps to reboot the iMist2 gateway:

  • In the “Connection Tab” on iMistAway.com or on the iMistAway mobile app, click on the blue “Reboot” button that is circled in the image above.
    • The unit status circle at the top of the screen will turn black (“Gateway Not Connected”) for 2-3 minutes, indicating that the gateway is rebooting.
  • Once the gateway comes back online, observe the unit status circle at the top of the screen to confirm that the unit and gateway were able to reconnect.
    • If the unit status circle updates to a Green (ok), Blue (no recent mist), Yellow (warning), or Red (error) color, then the misting unit and gateway have reconnected.
    • If the unit status circle updates to Gray and “Unit Not Connected: Node Not Responsive” is still displayed at the top of the screen, then the misting unit and gateway have still not reconnected and the node on the unit will need to be rebooted.

To reboot the node on the unit, perform the following steps on the controller for the misting unit:

  • Ensure that the node is plugged into the back of the controller.
  • Power cycle the misting unit by unplugging the power cable from the home’s outlet. After plugging the power cable back in, observe the display on the controller as it goes through the following boot up procedure:
    • “Mist” -> “Away” -> “Gen 1.3” or “Gen 3P” -> “PR ###” -> ~ 10 sec pause -> *iMist2 Node Check*
    • It is critical that you confirm that the controller displays “IM2 On” during the iMist Node Check. If “IM OFF” is displayed instead, the node on the unit has failed and must be replaced.
  • After the unit has been successfully power cycled, wait 5-10 minutes and check the status of the unit on your iMistAway app.
    • If the unit status circle updates to a Green (ok), Blue (no recent mist), Yellow (warning), or Red (error) color, then the misting unit and gateway have reconnected.
    • If the unit status circle updates to Gray and “Unit Not Connected: Node Not Responsive” is still displayed at the top of the screen, then the misting unit and gateway have still not reconnected. The node on the unit has failed and will need to be replaced.